Three Point One

WordPress 3.1 is out, and I’ve just upgraded a few of my sites (including this one). A few observations spring to mind immediately:

  • Installation was, of course, a breeze
  • The new admin bar is great. What would make it awesome is if developers (i.e. me) can add item to it: links to plugins, sparklines etc…
  • Network admin has been sensibly moved to a separate place than the standard admin sytem. Can we add items to the network admin menu? I guess so. I also hope that network (or WPMU) plugins will continue to work.
  • Not tried the new internal linking feature as I always use the raw HTML editor, but as I’ve been writing something similar for my day job recently I can imagine how it work

I’m looking forward to testing my plugins with 3.1, and writing some great new ones.

5 Responses to “Three Point One”

  1. George

    Hi Chris,

    Secure invites has a problem with buddypresson 3.1.

    if you go to http://viewery.com and comment on the activity wall, you will see the error.

    Appended is the error message.

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /var/www/sites/George/viewery.com/subdomains/www/html/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php:183) in /var/www/sites/George/viewery.com/subdomains/www/html/wp-content/plugins/wordpress-mu-secure-invites/secure_invite.php on line 242

    Btw thank you for your great plugins!

  2. ??

    Hello, after installing the Secure invites, 3.1 (multi-user) can not under normal use, when the user receives this connection & mail = xxx@xx.xx, open this link not work correctly registered.

  3. chris

    Can I check exactly what the problem is, please? The invited user gets their invitation email OK, but the link doesn’t work – is that it?